Gönderen Konu: Realflow Sorunsalı  (Okunma sayısı 15390 defa)

0 Üye ve 1 Ziyaretçi konuyu incelemekte.

Çevrimdışı KKpr

  • Deneyimli
  • ***
  • İleti: 1030
    • Profili Görüntüle
Realflow Sorunsalı
« : Mayıs 31, 2013, 01:18:12 ÖÖ »
Şu günlerde realflow'u sağlam bir biçimde kasıyorum fakat o mu beni kasıyor ben mi onu orada tam anlaşabilmiş değiliz.Şöyle ki;

Çakma kayalara benzettiğim ve deforme olmuş plane'den oluşturduğum bir sahilim var ve bu sahilimi domain içine oturtup cube/emitter ile ana su kaynağımı oluşturuyorum ve 100 küsürüncü frame'e kadar simüle ediyorum.Buraya kadar her şey normal.Ne zaman son frame'de initial frame'i ayarlamaya kalksam cube'ten cube domainin ortasına yerleşiyor ve oluşturduğum particuller yok oluveriyor.Cube'ün domainin ortasına gelmesini engellesem bu sefer de son frame'deki particulleri direk iptal edip simüle ettiği halde particul generate etmiyor.

Ben mi bir yerde hata yapıyorum anlamadım gitti.Bir kaç tutorial açtım atladığım bir nokta var galiba diye herkes benimle aynı şeyi yapıyor fakat onda oluyor bende olmuyor.

Nasıl bunun altından kalkabilirim ?


  • Motion Graphic Artist

Çevrimdışı Hızır KAYA (Aloha34)

  • Üye
  • **
  • İleti: 251
    • Profili Görüntüle
    • __V F X__
Ynt: Realflow Sorunsalı
« Yanıtla #1 : Mayıs 31, 2013, 12:09:09 ÖS »
Tam anlayamadım nasıl hareket ediyor? key mi verdin?
chache leri tamamen silip (manuel) tekrar simule ettiğinde aynı sonuc oluyormu denedinmi.
bendede bazen  realde sapıttımı sapıtıyor.ben tüm chache i silip tekrar alıyorum düzeliyor. ama şu hareket olayını anlamadım
  • 3D Generalist

Çevrimdışı KKpr

  • Deneyimli
  • ***
  • İleti: 1030
    • Profili Görüntüle
Ynt: Realflow Sorunsalı
« Yanıtla #2 : Mayıs 31, 2013, 12:21:55 ÖS »
Key falan yok.Re-simulate etmeye kalktığımda cube domainin ortasına geliyor.Ctrl+a yaptığımda.Mevcut durması gereken particul'ler de yok oluyor.Cache ile olacağını sanmıyorum çünkü cache'lik çok büyük bir durum yok.Bilerek ufak scale'lerde çalıştım ama bana mısın demedi.

Ha unutmadan yazayım.Dün evde denerken cube'ün sınırlarının domainin dışına çıktığında bunu yaptığını fark ettim.Bir kaç milim içeri alıp tekrar denediğimde bu sefer de initial frame ettiğim zaman particuller yok oluyor.Yani initial frame'i hiç yapmamışım gibi oluyor.
  • Motion Graphic Artist

Çevrimdışı KKpr

  • Deneyimli
  • ***
  • İleti: 1030
    • Profili Görüntüle
Ynt: Realflow Sorunsalı
« Yanıtla #3 : Mayıs 31, 2013, 12:39:16 ÖS »
  • Motion Graphic Artist

Çevrimdışı Hızır KAYA (Aloha34)

  • Üye
  • **
  • İleti: 251
    • Profili Görüntüle
    • __V F X__
Ynt: Realflow Sorunsalı
« Yanıtla #4 : Mayıs 31, 2013, 12:47:10 ÖS »
Chachelik büyük durum derken.büyüklükle alakalı değil.simule ettiğinde dosyalara kayıt alıyor ya, sonuçta orada rakkamlı sıralı dosyalar oluşturuyor.oralarda bir yerde bir sıkntı olabilir daha önce oldu bana.tüm anime cıktıları klasorlerın içinden elle silip tekrar baştan simüle ettiğimde olmustu.chach i sil dememdeki kasıt buydu. bir sayı sırası hatası sapıtmasına neden oluyor olabilir.ama şu artaya gelmesini halen çözemedim.hiç karşılaşmadım.

hee birde sahnene bir k-volume eklersen iyi olur.derleyip toparlar ve domain dışına çıkan partikulleride sileceğinden belki sorunu çözer.(kvolume domainle aynı boyutta olmalı)
aklıma gelen bunlar.
  • 3D Generalist

Çevrimdışı Blacker

  • Üye
  • **
  • İleti: 323
    • Profili Görüntüle
Ynt: Realflow Sorunsalı
« Yanıtla #5 : Mayıs 31, 2013, 12:56:55 ÖS »
sahneyi paylaşsan daha hızlı sonuç alınır

Çevrimdışı KKpr

  • Deneyimli
  • ***
  • İleti: 1030
    • Profili Görüntüle
Ynt: Realflow Sorunsalı
« Yanıtla #6 : Mayıs 31, 2013, 13:21:25 ÖS »
  • Motion Graphic Artist

Çevrimdışı Blacker

  • Üye
  • **
  • İleti: 323
    • Profili Görüntüle
Ynt: Realflow Sorunsalı
« Yanıtla #7 : Mayıs 31, 2013, 13:49:05 ÖS »
sen sanırım 2013 kullanıyorsun bende 2012 var hata mesajı verdi neyse sd dosyası ile bir sahne oluşturup denedim cube ortaya gitmedi. bir dene sahne açmaz ise Cube ait menüde Sd<>Curve  yaptım sadece kendi sahnende deneye bilirsin
http://www.dosya.tc/server10/UNFQcR/bs.rar.html
« Son Düzenleme: Mayıs 31, 2013, 13:54:05 ÖS Gönderen: Mustafa Sarıçay »

Çevrimdışı Hızır KAYA (Aloha34)

  • Üye
  • **
  • İleti: 251
    • Profili Görüntüle
    • __V F X__
Ynt: Realflow Sorunsalı
« Yanıtla #8 : Mayıs 31, 2013, 13:53:15 ÖS »
Bende denedim sorun gözükmedi
  • 3D Generalist

Çevrimdışı KKpr

  • Deneyimli
  • ***
  • İleti: 1030
    • Profili Görüntüle
Ynt: Realflow Sorunsalı
« Yanıtla #9 : Mayıs 31, 2013, 14:03:56 ÖS »
Mustafa senin sahnede cube'ün yerini oynattım ve simule ettim ardından use initial state diyip resetlemek istedim 100. frame'i sıfır olarak alsın diye gene particulleri silip cube'ü eski yerine aldı.
  • Motion Graphic Artist

Çevrimdışı Blacker

  • Üye
  • **
  • İleti: 323
    • Profili Görüntüle
Ynt: Realflow Sorunsalı
« Yanıtla #10 : Mayıs 31, 2013, 15:06:04 ÖS »
cube olayına şaşırdım defalarca resetledim,position curves  değişiklik yada bir anahtar yok,bende bir sıkıntı yok valla 100den başlarak denedim  particle üretiyor.istersen bir altaki sahneyi dene
export menüsünde update timeline cache diye buttonu dene reset attıkdan sonra.
http://www.dosya.tc/server10/h51bYB/bb.rar.html

Çevrimdışı KKpr

  • Deneyimli
  • ***
  • İleti: 1030
    • Profili Görüntüle
Ynt: Realflow Sorunsalı
« Yanıtla #11 : Mayıs 31, 2013, 15:39:18 ÖS »
Sahneyi indirdim update cahce'i de yaptım şimdi de particul üretmiyor..Ben bir yerde hata yapıyorum galiba. Realflow 2012 kullanıyorum bu arada büyük ihtimalle sizinle aynı versiyon olması lazım.

Kendi sahnemde denedim bu sefer oldu ama gene cube kalktı gravity'e oturdu.Birebir uyguluyorum şunu tutorial ile yeter ki olması için yok arkadaş nerede patlıyorum anlamadım.

http://i.imgur.com/O10P24z.jpg
« Son Düzenleme: Mayıs 31, 2013, 15:43:02 ÖS Gönderen: Kaan Kapar »
  • Motion Graphic Artist

Çevrimdışı KKpr

  • Deneyimli
  • ***
  • İleti: 1030
    • Profili Görüntüle
Ynt: Realflow Sorunsalı
« Yanıtla #12 : Temmuz 30, 2013, 12:15:08 ÖS »
Konu kirliliği olmaması adına tekrardan buraya yazayım. Youtube üzerinden bir tutorial yapıyordum 3. part'a kadar her şey güzel giderken splash'te patladım. Bu sefer ne şaşırtıcıdır ki aynı sorun başkalarında da var.

Öncelikle tutorial linkini vereyim.


Ardından, eleman burada exclusive links kullanarak cache edilmiş simülasyona splash ekliyor. Spesifik olarak gittim bu tutorial'da bilerek. Fakat eleman simulate etmeye başladığında her şey doğru giderken iş bana gelince cube'ün köşelerinden splash generate ediyor durduk yere ve inanılmaz şekilde makineyi zorluyor. Exclusive linkleri kontrol etmeleri gerektiğini yazmış ama birebir aynısı. Genede böyle olmasına anlam veremedim.

Bu da programdan bir görüntü,
  • Motion Graphic Artist

Çevrimdışı Hızır KAYA (Aloha34)

  • Üye
  • **
  • İleti: 251
    • Profili Görüntüle
    • __V F X__
Ynt: Realflow Sorunsalı
« Yanıtla #13 : Temmuz 30, 2013, 12:43:11 ÖS »
K_volume'u domain'in içerisinde tutarsan kenarlardaki splashları hesaplamaz. domain den daha küçük olsun yani.senin k_volume gördüğüm kadarıyla en dışta duruyor.
  • 3D Generalist

Çevrimdışı KKpr

  • Deneyimli
  • ***
  • İleti: 1030
    • Profili Görüntüle
Ynt: Realflow Sorunsalı
« Yanıtla #14 : Temmuz 30, 2013, 12:49:04 ÖS »
K_volume zaten splash'ın dışında durması gereken bir şey değil mi? Tutorial'daki eleman da dışarıda tutuyor. Ki bildiğim kadarı ile infinite space'te uçuşan particul'ları kesmek için kullanılan domain olduğundan mantıken de dışında durması gerekmiyor mu?

Genede denedim içeri aldım aynı sorun devam etti.
  • Motion Graphic Artist

Çevrimdışı Hızır KAYA (Aloha34)

  • Üye
  • **
  • İleti: 251
    • Profili Görüntüle
    • __V F X__
Ynt: Realflow Sorunsalı
« Yanıtla #15 : Temmuz 30, 2013, 12:52:32 ÖS »
Evet haklısın kesmek için kullanılıyor volume zaten.o yuzden ben splash domaınden kucuk tutuyorumkı ıstemedıgım yerlerde splash hesaplamasın.Elemana fazla bakma sen bir yeri çek etmiştir o sırada tutoriali durdurmustur ne bılıyım senın benım gozumuzden de kacıyor ıste.çok basıma geldı.birde splash da domaınden kucuk olsun.
  • 3D Generalist

Çevrimdışı KKpr

  • Deneyimli
  • ***
  • İleti: 1030
    • Profili Görüntüle
Ynt: Realflow Sorunsalı
« Yanıtla #16 : Temmuz 30, 2013, 13:04:44 ÖS »
Dediklerini yaptım fakat bana mısın demiyor gene köşelerden generate ediyor.
  • Motion Graphic Artist

Çevrimdışı Hızır KAYA (Aloha34)

  • Üye
  • **
  • İleti: 251
    • Profili Görüntüle
    • __V F X__
Ynt: Realflow Sorunsalı
« Yanıtla #17 : Temmuz 30, 2013, 13:06:38 ÖS »
hımm olmaması lazım.birde velocity yi falan kısmayı dene yogunluktan falan olabılır.cok dusuk bır ıhtımal gercı.
  • 3D Generalist

Çevrimdışı KKpr

  • Deneyimli
  • ***
  • İleti: 1030
    • Profili Görüntüle
Ynt: Realflow Sorunsalı
« Yanıtla #18 : Temmuz 30, 2013, 13:14:35 ÖS »


Tamamen farklı bir şey denemeye kalktım bu sefer bir kaç frame sonra gene aynı sorunu yapmaya başladı. Sanırım exclusive linklemede bir sorun var. Ya da particul ayarlarında.

Acaba emitter'ların stream'ini YES olarak mı ayarlasam?
  • Motion Graphic Artist

Çevrimdışı Blacker

  • Üye
  • **
  • İleti: 323
    • Profili Görüntüle
Ynt: Realflow Sorunsalı
« Yanıtla #19 : Temmuz 30, 2013, 14:44:14 ÖS »
Simulate buttonun üzerinde option seçeginde tıklayınca  Time step ayarlarında 1-333 degeriniyle oynamak gerekebiliyor bazen düzgün particle oluşumu için.resolve quality en az medium yaparsan iyi olur.sorunu yanlış anlamışda olabilirim
edit: sanırım sadece yere çarptıgında splash oluşmasını istiyorsun eger öyle ise sadece zemine bir kvolume ekleyeceksin, inverse yapıp  exculiseve link içindeki splashın altına  kvolume2 atarsan sadece zemine indinginde splash oluşur. diger kvolume1 ise domain içinde
« Son Düzenleme: Temmuz 30, 2013, 15:11:34 ÖS Gönderen: Mustafa Sarıçay »